Author Topic: Voidrazor Anti-Grief: geekguy44  (Read 1614 times)

Dasubliminal

  • Minecraft moderator
  • Jr. Member
  • *
  • Posts: 86
  • Always watching you on Minecraft. Always.
    • dasub.com
Voidrazor Anti-Grief: geekguy44
« on: December 25, 2011, 04:30:33 pm »
Those rascally rabbits are at it again! Griefers from far and wide coming on the Minecraft server to make it look horrible, the nerve! The solution? Call 1800 trollurface to get in contact with:

The Voidrazor Anti-Griefing Team Extraordinaire

They're hip! They're cool! They're mentally unstable! All the ingredients to make the perfect anti-griefer!

So sit your asses down children while I recite to you this epic tale of trolololziness.

Chapter 1
What? Griefers on mah server?


It was a fine day and the sun was shining. Unbeknownst to the citizen of Voidrazia trouble was a-brewin'. And trouble's name was geekguy44.

01:39:44 geekguy44 logged in
01:39:51 geekguy44: hi!


This horrible griefer knew the finer points of griefing, like how using trees makes it rather hard to roll back. So after about an hour of getting away with his dastardly acts, in logs two members of the Anti-Griefing team, vDepth and Dasubliminal.

02:45:13 vDepth logged in
02:45:13 [VANISH] vDepth disappeared.
02:46:12 geekguy44: hi
02:46:57 dasubliminal logged in
02:46:57 [VANISH] dasubliminal disappeared.


So Das decides to play it pretty straight to start with, you know, standard Moderatorish kind of banter, but there's no point me explaining it to you, here's the conversation in it's entirety:

02:47:23 [MOD] dasubliminal: I like what you've done with the place
02:47:31 geekguy44: mhmmmm
02:47:53 geekguy44: your using md so i cant see you using tab (FYI: Not using MD (Monster Disguise))
02:48:00 geekguy44: nice
02:48:17 geekguy44: squid?
(Das uses rollback player command)
02:48:36 geekguy44: haha
02:48:42 geekguy44: roll back fail
02:48:50 geekguy44: i love trees
02:48:51 [MOD] dasubliminal: Yeah we're working on the sapling thing
02:49:04 geekguy44: hmmm
02:49:14 geekguy44: you need buyilding protection
02:49:31 geekguy44: everything is breakable
(Das uses rollback time to roll back everything since this guy joined)
02:49:35 [MOD] dasubliminal: Much better
02:49:38 [Admin] vDepth: Problem?
02:49:41 [MOD] dasubliminal: Well, enjoy
02:49:41 geekguy44: yep
02:50:03 geekguy44: might as well actually build now
02:50:30 [MOD] dasubliminal: Go right ahead
02:51:30 geekguy44: but was i correct as saying your useing md so i cant see you in the
02:51:34 [MOD] dasubliminal: Nope
02:51:35 geekguy44: player list?
02:51:38 [MOD] dasubliminal: Not using md
02:51:38 geekguy44: oh
02:51:41 [Admin] vDepth: MD, pffft.
02:51:58 [Admin] vDepth: Thats just there to derp about with.
02:52:01 [MOD] dasubliminal: Your hacks are just out of date
02:52:05 [MOD] dasubliminal: Get new ones
02:52:35 geekguy44: my hacks consist of a couple days worth of fooling around with the minecraft
02:52:37 geekguy44: code
02:52:47 [MOD] dasubliminal: Like I said
02:52:49 [MOD] dasubliminal: Make them better
02:52:54 [MOD] dasubliminal: A few days isn't enough
02:52:59 geekguy44: yea
02:53:03 [MOD] dasubliminal: This server's been live for months now
02:54:45 geekguy44: voxelsniper?
02:55:12 [VANISH] dasubliminal reappeared.


Now for lolz, we decide to mount geekguy's head. Much fun was had.

02:55:24 geekguy44: yep
02:55:59 [VANISH] vDepth reappeared.
02:56:13 geekguy44: jockey brush
02:57:17 [SEVERE] NC: geekguy44 failed moving.running.vertical. VL 6329 (Speed hack attempt fail)


Das spawns a buttload of those villagers that look like Squidward.

02:57:27 geekguy44: lol

Geekguy starts hitting the Squidwards

02:58:15 [MOD] dasubliminal: Man why you hatin' on Squidward
02:58:20 [MOD] dasubliminal: He ain't a bad guy
02:58:32 [MOD] dasubliminal: Just doin' his duty


So we've had our fun, or so it seems. We both dismount and vanish again, but then geekguy opens himself up to some trolling we hadn't anticipated.

03:00:02 [MOD] dasubliminal: Yeah you're boring when you're not griefing
03:00:19 [MOD] dasubliminal: Get your friends on
03:00:28 geekguy44: were you watching me the whole time?
03:00:34 [MOD] dasubliminal: I wanna have a griefer race :D
03:00:37 [MOD] dasubliminal: Of course lol
03:00:46 [MOD] dasubliminal: Wouldn't be much of a Mod if I wasn't
03:00:53 geekguy44: lol
03:01:01 [Admin] vDepth: We let some other guy go at it for about 2 hours just a few days ago
03:01:07 [MOD] dasubliminal: Yeah, it was a blast
03:01:16 [MOD] dasubliminal: Watching all his griefing disappear, classic
03:01:25 [MOD] dasubliminal: He didn't know what the hell was going on
03:01:51 geekguy44: since when did the implament a feture to get rid of trees?
03:02:01 [MOD] dasubliminal: Worldguard?
03:02:02 [MOD] dasubliminal: Not sure
03:02:15 [MOD] dasubliminal: Oh wait no the rewind plugin (Lol)
03:02:22 [MOD] dasubliminal: Different thing completely
03:02:41 [MOD] dasubliminal: Logs the sapling's growth into a tree and applies the logs to the grown tree
03:02:45 [MOD] dasubliminal: Most helpful
03:02:53 [MOD] dasubliminal: Good if a normal rollback doesn't cut it
03:02:59 geekguy44: you should save a backup of ther server give evey person wands
03:03:07 geekguy44: and have fun with commands
03:03:12 [MOD] dasubliminal: Lol
03:03:16 [MOD] dasubliminal: That's a terrible idea
03:03:48 [MOD] dasubliminal: But hey you seem like an OK guy
03:04:02 [MOD] dasubliminal: We could probably give you commands for a few minutes, what's the worst that could happen


Chapter 2
Griefing the griefer


So he wants worldedit permissions eh? Why not give him the whole damn Moderator permission set I say! So the nefarious vDepth decides to act on geekguy's suggestion and give him "Mod priveleges". Which as we all know is just a [MOD] tag in front of your name.

03:04:35 [MOD] dasubliminal: Well there you go
03:04:37 [MOD] dasubliminal: Go nuts
03:04:48 [MOD] geekguy44: still dont have permisson


Chapter 3
Have you tried turning it off and on again?


Aw, he doesn't have permission to use the worldedit wand? Time for Voidrazor Tech Support to step in.

03:04:54 [MOD] dasubliminal: Try relogging
03:04:57 geekguy44 lost connection: disconnect.quitting
03:05:01 geekguy44 logged in
03:05:13 [MOD] geekguy44: still dont
03:05:15 [MOD] dasubliminal: Hm
03:05:19 [MOD] dasubliminal: Try restarting your client
03:05:24 geekguy44 lost connection: disconnect.quitting
03:05:47 geekguy44 logged in
03:05:56 [MOD] geekguy44: nope


Ok so turning it off and turning it back on again didn't work.

Twice.

Well obviously it's a Java problem then, right?

03:06:03 [MOD] dasubliminal: Java version?
03:06:14 [MOD] geekguy44: up to date
03:06:21 [MOD] dasubliminal: What number though?
03:06:27 [MOD] geekguy44: i think
03:06:41 [MOD] dasubliminal: Like 1.5, 2.6 whatever it is
03:06:54 [MOD] dasubliminal: Cos there's a devmod they released that's not officially public
03:07:05 [MOD] dasubliminal: But if you update it you'll silently get the update
03:07:30 [MOD] dasubliminal: It'll still say it's the previous version, but you'll have the new features
03:07:55 [MOD] dasubliminal: We only did it today so it's probably not public knowledge yet
03:08:46 [MOD] geekguy44: 6 somthing
03:08:51 [MOD] geekguy44: cant find it
03:08:55 [MOD] dasubliminal: That doesn't really help lol
03:09:03 [MOD] geekguy44: lol
03:09:04 [MOD] dasubliminal: But 6 is the most recent version at least
03:09:26 [MOD] dasubliminal: Not sure if you need to reinstall it or not
03:09:30 [MOD] geekguy44: most usless feture ever
03:09:32 [MOD] dasubliminal: To get the silent update I mean
03:09:34 [MOD] dasubliminal: Hm?
03:10:12 Choobert logged in
03:10:12 [VANISH] Choobert disappeared.
03:11:12 [MOD] dasubliminal: Can you at least bypass NoCheat now?
03:11:22 [MOD] geekguy44: nope
03:11:26 [MOD] dasubliminal: Sheesh
03:11:32 [MOD] geekguy44: fly still not working
03:11:35 [MOD] dasubliminal: You sure you're running 6.x Java?
03:11:47 [MOD] dasubliminal: Sounds like you downloaded a dud
03:11:51 [MOD] geekguy44: yeah
03:11:58 [MOD] dasubliminal: Or the Minecraft client corrupted the Java install or something
03:12:14 [MOD] dasubliminal: Ah well, if you're cool with not using commands don't worry about it I guess
03:12:20 [MOD] geekguy44: ill just use pos1
03:12:29 [MOD] dasubliminal: Yeah go for it
03:12:30 [MOD] geekguy44: nope
03:12:49 [MOD] dasubliminal: Tbh I have no idea what that is, but you're a Mod now so anything goes :P
03:14:00 [MOD] geekguy44: i cant even use md
03:14:12 [MOD] dasubliminal: Yeah that's definitely a Java thing
03:14:17 [MOD] dasubliminal: I couldn't use it yesterday either
03:14:23 [MOD] dasubliminal: Today it's all good though
03:16:21 geekguy44 lost connection: disconnect.quitting
03:16:25 geekguy44 logged in
03:16:41 [MOD] dasubliminal: That was quick lol
03:16:49 [MOD] geekguy44: mmmmmmmmmmm
03:16:53 [MOD] dasubliminal: Usually takes longer for the install to run
03:17:01 [MOD] geekguy44: i didnt install
03:17:06 [MOD] dasubliminal: Oh
03:17:26 [MOD] geekguy44: will now
03:17:28 geekguy44 lost connection: disconnect.quitting


...wait what? He's actually going to reinstall Java? Surely not...

Before too long:

03:22:18 geekguy44 logged in (Note the time tags, about 5 minutes have passed. I think this guy may have actually reinstalled his Java xD)
03:22:21 [MOD] dasubliminal: Wb
03:22:27 [MOD] dasubliminal: All run smoothly?
03:22:34 [MOD] geekguy44: nope
03:22:37 [MOD] dasubliminal: Oh?
03:22:43 [MOD] dasubliminal: It didn't install?
03:22:49 [MOD] geekguy44: it did
03:22:53 [MOD] dasubliminal: Oh that's good
03:23:16 [MOD] geekguy44: command still says i don't have permisson
03:23:52 [MOD] dasubliminal: Hmmm
03:24:06 [MOD] dasubliminal: Ok you'll need to check your Java version real quick
03:24:12 [MOD] dasubliminal: It's not too hard
03:24:31 [MOD] dasubliminal: Oh but before I do that
03:24:52 [MOD] dasubliminal: Did you have any Java scripts or Applications running in the background during the Java install?
03:24:58 [MOD] geekguy44: no
03:25:02 [MOD] dasubliminal: Cos that would have made things difficult
03:25:03 [MOD] dasubliminal: Ok then
03:25:05 [MOD] geekguy44: i closed them out
03:25:08 [MOD] dasubliminal: Good man


Chapter 4
Have you tried turning it off and on again again?


So Java reinstall didn't fix his permissions, that's a shame. It must be his virus scanner blocking the permissions then :P

03:25:17 [MOD] dasubliminal: You're running a virus scanner atm?
03:25:24 [MOD] dasubliminal: Avast, AVG, Norton etc?
03:25:28 [MOD] geekguy44: yeah
03:25:34 [MOD] dasubliminal: Which one specifically?
03:25:42 [MOD] dasubliminal: Not all of them affect the latest install
03:25:43 [MOD] geekguy44: AVG
03:25:45 [MOD] dasubliminal: Oh
03:25:51 [MOD] dasubliminal: That's the worst :/
03:26:03 [MOD] dasubliminal: You may have problems logging into Minecraft soon
03:26:09 [MOD] dasubliminal: Not to worry though
03:26:24 [MOD] dasubliminal: Java is picky at best so we'll run troubleshooting
03:26:55 [MOD] dasubliminal: Shut down or disable the Live Scanner on AVG
03:26:59 [MOD] dasubliminal: But first
03:27:06 [MOD] dasubliminal: You need to do this in order
03:27:12 [MOD] dasubliminal: 1: Close Minecraft
03:27:16 [MOD] dasubliminal: 2: Close AVG
03:27:22 [MOD] dasubliminal: 3: Reboot Minecraft
03:27:34 [MOD] dasubliminal: There's one other option if this doesn't work
03:27:44 [MOD] geekguy44: reinstall
03:27:44 [MOD] dasubliminal: But it's pretty annoying so I don't want to make you do it just yet
03:27:46 [MOD] dasubliminal: No
03:27:49 [MOD] dasubliminal: Nothing like that lol
03:27:58 geekguy44 lost connection: disconnect.endOfStream
03:27:59 [MOD] dasubliminal: Well, unless the step after this one fails heh
03:30:23 geekguy44 logged in
03:30:34 [MOD] dasubliminal: Okie doke
03:30:44 [MOD] geekguy44: avg wont let me end it
03:30:51 [MOD] dasubliminal: Hm
03:31:03 [MOD] dasubliminal: Do you know how to Force Quit programs?
03:31:07 [MOD] geekguy44: yea
03:31:14 [MOD] geekguy44: i tryed
03:31:14 [MOD] dasubliminal: Using the process meniu
03:31:17 [MOD] dasubliminal: I see
03:32:05 [MOD] dasubliminal: Ok so AVG won't quit. Hm


Well at least he tried. Friggin AVG. Coded so badly it even effects Minecraft permissions. Well what else can we try then?

03:32:20 [MOD] dasubliminal: The only other 2 things I can think of are kind of desparate
03:32:30 [MOD] dasubliminal: But you can try them, they should help
03:32:39 [MOD] dasubliminal: The first is just rebooting your PC
03:32:53 [MOD] dasubliminal: The second is doing a complete Minecraft reinstall including all mods
03:33:01 [MOD] dasubliminal: I'm assuming you're running Epsilon?
03:33:22 [MOD] dasubliminal: It did indeed
03:33:23 [MOD] geekguy44: no my own griefing client i coded


Ok ok ok, just hold the phone a second here. He can code his own griefing client but he doesn't realise that we're trolling him by saying Java was the reason his permissions weren't working?

Just thought I'd mention that, I got a good laugh out of it. Moving on...

03:33:36 [MOD] dasubliminal: Ah cool
03:33:49 [MOD] dasubliminal: That could be the problem, but we'll ignore that for now
03:33:59 [MOD] dasubliminal: Did you want to try a reboot?
03:34:05 [MOD] geekguy44: yeah
03:34:07 [MOD] dasubliminal: It's a long shot, but it does tend to fix things
03:34:11 [MOD] dasubliminal: Cool man
03:34:13 geekguy44 lost connection: disconnect.endOfStream


Yes, you read correctly. We just convinced a guy to reboot his computer to fix Minecraft permissions. Did he actually do it? We'll never know. But the timestamps seem to indicate that he did.

03:39:27 geekguy44 logged in
03:39:36 [MOD] dasubliminal: Heyo
03:39:38 [MOD] geekguy44: nope
03:39:42 [MOD] dasubliminal: Dang
03:39:48 [MOD] geekguy44: brb
03:39:49 geekguy44 lost connection: disconnect.quitting


I personally though he was never coming back. But I was mistaken. Without us saying anything he had actually completely reinstalled Minecraft, even wiping his hacked client out for a vanilla one. So he returned some time later:

03:47:10 geekguy44 logged in
03:47:15 [MOD] geekguy44: hi
03:47:41 [MOD] geekguy44: I reinstalled minecraft (My reaction at the time: WTF really? I didn't even ask you to do that!)
03:47:50 [MOD] dasubliminal: Ah cool beans
03:47:56 [MOD] dasubliminal: Your mods all still work etc?
03:48:02 [MOD] geekguy44: and wand atill not working
03:48:05 [MOD] dasubliminal: Ffs
03:48:20 [MOD] geekguy44: no i have a freash new unmodded minecraft
03:48:27 [MOD] dasubliminal: Oh right


I was sure he suspected something was up by this point. But if he did he was hiding that fact pretty well. So the conversation continued:

03:48:32 [MOD] dasubliminal: Ok give me a sec
03:48:39 [MOD] dasubliminal: I'm gonna check the configs real quick (Proceeds to "check the configs")
03:48:45 [MOD] geekguy44: K
03:50:49 [MOD] dasubliminal: Ok everything looks like it's in order
03:51:00 [MOD] geekguy44: nope
03:51:05 [MOD] dasubliminal: Do you have Skype or something?
03:51:17 [MOD] dasubliminal: This would be a lot easier to sort out that way imo
03:51:25 [MOD] geekguy44: yea but my mic is broken (I didn't pick up on this at the time, but I was informed by vDepth that this basically means "I'm a squeaker". It explains a lot)
03:51:30 [MOD] dasubliminal: Ah I see
03:51:42 [MOD] dasubliminal: That's ok, we can just use the text chat
03:51:52 [MOD] dasubliminal: I just want to link you some help files
03:52:06 [MOD] dasubliminal: Minecraft's no good for that
03:52:12 [MOD] geekguy44: Yea
03:52:25 [MOD] dasubliminal: Just /msg me it if you don't want anyone else to see it
03:53:39 [MOD] geekguy44: could you give me gamemode 1 so i can fly?
03:53:57 [MOD] dasubliminal: I can't swap game modes unfortunately :/
03:54:04 [MOD] geekguy44: Oh
03:54:19 [MOD] geekguy44: Then bunny hopping it is
03:54:20 [MOD] dasubliminal: Otherwise I'd be on creative too heheh
03:54:38 [MOD] dasubliminal: You don't have Steam or something?
03:54:43 [MOD] geekguy44: i do
03:54:50 [MOD] dasubliminal: Any sort of text chat thing I can paste help links into
03:54:58 [MOD] geekguy44: steam
03:55:09 [MOD] dasubliminal: Is it the same name as your MC account?
03:55:13 [MOD] geekguy44: yea
03:55:16 [MOD] dasubliminal: Kk
03:55:18 [MOD] dasubliminal: Give me a sec
03:57:25 [MOD] dasubliminal: Bleh my Steam is really slow tonight, bear with me
03:58:48 [MOD] dasubliminal: Ok invite sent
03:58:59 [MOD] geekguy44: got it
03:59:00 [MOD] dasubliminal: Should be from "Voidrazor: Tech Team
03:59:23 [MOD] geekguy44: added
03:59:58 [MOD] dasubliminal: Cool beans


Chapter 5
Technical Support


So I got him on Steam to give him some "technical support". Here's the saddest part of the story...

I accidently closed the Steam chat window after the trolling had concluded, wiping out our entire conversation. As such, this is the conversation from my memory. I wrote it down straight afterwards so I'm pretty sure most of it's there, but I'm rather bummed I lost the convo nonetheless.

Voidrazor: Tech Team: Ok so I've got you to disconnect/reconnect to the server, which didn't work.
Voidrazor: Tech Team: You've completely shut down and restarted the Minecraft client, which also didn't work.
Voidrazor: Tech Team: And you've completed a full reinstall of Java, that also didn't have the desired effect.
Voidrazor: Tech Team: Is everything in order so far?
geekguy44: yes
Voidrazor: Tech Team: Ok so next we tried to disable the AVG antivirus system which unfortunately couldn't be accomplished, I don't think that was the problem anyway to be honest.
Voidrazor: Tech Team: Next was a complete reboot of your PC to hopefully fix the Java installation, that was unsuccessful.
Voidrazor: Tech Team: And finally a complete reinstall of the Minecraft client.
Voidrazor: Tech Team: Were all these steps completed?
geekguy44: yes
geekguy44: but you might need to restart the server
Voidrazor: Tech Team: Ah ok, I'll see what I can do.


So vDepth waved his magical adminium wand once more and a server restart was completed:

04:05:43 [MOD] dasubliminal: Ok Server Reboot is scheduled
04:05:48 [MOD] geekguy44: k
04:05:51 [MOD] dasubliminal: Should happen soon
04:06:05 CONSOLE: Forcing save..
04:06:05 CONSOLE: Save complete.
04:06:06 <*Console> **SERVER IS RESTARTING**
04:06:12 CONSOLE: Stopping the server..
04:06:12 Stopping server
04:06:27 Starting minecraft server version 1.0.1
04:06:27 Loading properties
04:06:27 Starting Minecraft server
04:06:47 geekguy44 logged in
04:06:52 vDepth logged in
04:06:52 [VANISH] vDepth disappeared.
04:07:27 dasubliminal logged in
04:07:27 [VANISH] dasubliminal disappeared. (At this stage geekguy sent me a message on Steam saying he still couldn't use commands, why I wrote what I did next)
04:07:32 [MOD] dasubliminal: Ok so still no luck


So back to the Steam convo. Time to start linking him some "help videos".

FAQ: I noticed you didn't use the original videos of the following links. Why is this?
Because the original videos had advertising at the beginning the troll would have been unsuccessful.

On with the convo!

Voidrazor: Tech Team: Ok so that didn't do anything, I'll try to link you to those help videos I mentioned earlier, bear with me.
Voidrazor: Tech Team: Ok here's the first one:
Voidrazor: Tech Team: http://www.youtube.com/watch?v=woySeSNBL3o (Trololol)
geekguy44: seriously?
geekguy44: trying to troll me?
Voidrazor: Tech Team: ?
Voidrazor: Tech Team: Oh I'm so sorry!
Voidrazor: Tech Team: I was meant to link this video to a friend, my bad xD
geekguy44: right...
Voidrazor: Tech Team: My apologies, I'll try to find the right video for you now, one second.
Voidrazor: Tech Team: Ok this should be the right one now:
Voidrazor: Tech Team: http://www.youtube.com/watch?v=XZ5TajZYW6Y (Rickroll)
geekguy44: really dude?
Voidrazor: Tech Team: Oh man, I can't believe I did that again, man the Voidrazor staff are going to be so pissed that I did that xD
Voidrazor: Tech Team: Sorry I'm fairly new at this
Voidrazor: Tech Team: Please don't tell the staff that I messed up so much
geekguy44: I won't do that
Voidrazor: Tech Team: Ok, thank you very much
Voidrazor: Tech Team: So did you want me to find any more help videos?
geekguy44: no
Voidrazor: Tech Team: Ok no problem
Voidrazor: Tech Team: We hope you've had a pleasant experience using the Voidrazor Technical Team
Voidrazor: Tech Team: Have a nice day :)


He did include some sort of threat in the Steam conversation to do with griefing the server I'm assuming, but I can't remember exactly what he said so I didn't include it. But basically after this point he was /ban-ned with no explaination. I was informed by Mr. vDepth that he attempted to reconnect a few times after that but in any case, that end the epic saga of geekguy44. You will be missed.

Chapter 6
That thing that Das seems to put on the end of all his posts for no apparent reason


- Das